IIS7.5+php5.4连接mssql2008R2数据库

作者:笨小孩 发布于:2014-4-22 19:29 分类:环境架设

类似《php5.3连接mssql2005数据库


1、连接Sql server 2005以上版本的sql server(如sql server 2008),需要在机器上先安装 SQL Server Native Client :官方下载


2、先到微软网站下载 SQL Server Driver for PHP。备用下载:SQLSRV30.zip

 这是一个自解压的EXE文件,解压缩后你会得到以下文件:

QQ截图20140422192907.gif


其中的53、54表示就是php的5.3.x和5.4.x 版本,选择跟你php版本相匹配的;

将php_sqlsrv_54_nts_vc9.dll复制到php的ext目录中,并在php.ini中添加 extension=php_sqlsrv_54_nts_vc9.dll   接下来重新启动IIS 并运行phpinfo.php,来查看phpinfo的配置信息,如果看到下图信息,则说明可添加成功。


ps:没有对应5.5的dll只能用5.4的


标签: php MsSql IIS

发表评论:

手机版 | 
Copyright © 2012 lamp46.com All Right Reserved. sitemap